Ankündigung

Einklappen
Keine Ankündigung bisher.

SIP2Lync - Snom M9r- Verbindungsabbruch bei Rufannahme

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    SIP2Lync - Snom M9r- Verbindungsabbruch bei Rufannahme

    Hallo,

    derzeit beschäftige ich mich damit, ein Snom M9r an Lync bzw. S4B anzubinden. Soweit klappt das mit einer Testlizenz von SIP2Lync auch ganz gut.

    Es gelingt mir allerdings nicht, eingehende Anrufe am Mobilteil anzunehmen. Beim Annehmen bricht die Verbindung sofort ab. Als Fehlermeldung erhalte ich im OMGate-Log die Meldung

    "Proxy side Media negotiation failed";component="MediationServer"

    also ganz ähnlich wir Herr Schumacher in diesem Thread

    http://forum.ferrari-electronic.de/s...enommen-werden

    Vermutlich liegt es also an den Audio-Codecs. Interne Skype-Anrufe funktionieren übrigens, sobald die Telefonanlage bei eingehenden Anrufen im Spiel ist geht es nicht mehr.

    Ist es sinnvoll hierfür den Snom-Support oder doch eher Euren Support zu kontaktieren?

    Gruß
    Matthias
    Zuletzt geändert von MKremer; 23.01.2016, 11:36.

    #2
    Wie sieht denn im Syslog des Gateways beim ankommenden INVITE vom SIP2Lync Server das SDP aus - sind da zwei m=audio... Zeilen drin?
    Johann Deutinger
    Dipl.-Inf. / MCITP Lync 2010/2013, MCTS Exchange 2007/2010

    Kommentar


      #3
      Anbei das SDP aus dem Log. Einmal SIP2Lync mit .5.81 und einmal Snom mit .9.84

      Euer Support ist schon informiert und vermutlich auch gerade dran.

      Gruß
      Matthias
      SNOM_9_84_SDP-Table.txt
      SIP2Lync_5_81_SDP-Table.txt

      Kommentar


        #4
        Genau das selbe Problem

        Zitat von Johann Deutinger Beitrag anzeigen
        Wie sieht denn im Syslog des Gateways beim ankommenden INVITE vom SIP2Lync Server das SDP aus - sind da zwei m=audio... Zeilen drin?

        Ich habe genau das gleiche Problem, ebenfalls mit einer Testlizenz für SIP2Lync.

        Das SDP beinhaltet bei mir nur eine m=audio Zeile.
        m=audio 53052 RTP/AVP 0 8 115 13 118 97 101

        Können sie mir weiterhelfen?

        Kommentar


          #5
          Hallo,

          sind noch weitere Skype4B-Clients für den Test-User aktiv?

          Bei uns stellte sich letztendlich heraus, dass ein weiteres Tischtelefon, über welches der User angemeldet war, das Problem verursacht hat. Ebenso gilt dies für die Skype4B-App auf Smartphones. Der klassische Skype4B-Client auf PCs sollte dagegen keine Probleme machen.

          Viele Grüße
          Matthias

          Kommentar


            #6
            Hallo Matthias

            Nun, der Testuser ist über einen Skype4B-Client auf dem PC und über ein SIP2Lync "Dectphone" verbunden. Das Dectphone simuliere ich mit einem SIP-Softphone (X-Lite und Zoiper). Beide funktionieren leider nicht.

            Danke und Gruss!

            Kommentar


              #7
              Hallo,

              hast Du schon mal ein Hardware-DECT-Phone ausprobiert?

              Hab hier auch mal Zoiper auf einem Windows Phone getestet und es klappt in beide Richtungen.

              Gruß
              Matthias

              Kommentar


                #8
                Hallo Matthias

                Danke für die Antwort!

                Nun ich bin Momentan auf einem ganz anderen Pfad. Das Problem ist, dass er versucht RTP Daten an eine "falsche" IP zu senden.

                Im Invite from SIP2Lync sehe ich folgende SDP Info:
                a=candidate:1 1 UDP 2130706431 179.xx.xx.253 57480 typ host
                a=candidate:1 2 UDP 2130705918 179.xx.xx.253 57481 typ host
                a=candidate:2 1 UDP 2130705919 179.xx.x.2 52530 typ host
                a=candidate:2 2 UDP 2130705406 179.xx.xx.2 52531 typ host

                Er wählt hier candidate 1 mit ip 179.xx.xx.253. Das geht aber so nicht. (Netzwerktopologie). Mit candidate 2 könnte er allerdings ohne Probleme RTP Daten austauschen. Die Frage ist nun wie kriege ich das Gateway/SIP2Lync dazu candidate 2 zu verwenden?

                Eventuell bin ich auch auf einem falschen Pfad und verlaufe mich nun. Wenn du eine Idee hast bin ich dir sehr dankbar!

                Gruss
                B

                Kommentar


                  #9
                  Was Du noch einmal testen könntest, wäre im Skype4B-Server den Media Bypass zu aktivieren. Sowohl in der Trunkkonfiguration als auch global in der Netzwerkkonfiguration.

                  Sonst wäre es, wie gesagt, noch wichtig, dass erst einmal nur ein Client aktiv ist. Ist denn die zweite IP-Adresse ein weiterer Client? Bei mir taucht bei typ host nur eine IP auf, aber der Testuser ist sonst auch nirgends angemeldet.

                  Gruß
                  Matthias

                  Kommentar


                    #10
                    Hallo B,
                    Hallo Matthias,

                    @B: bekommst du mehrere SDP's? Siehst du in der sip2lync Log. Dann kannst du im SIP2Lync Configurator den SDP Index setzen um nicht den Ersten "m=" zu verarbeiten.
                    Zu den SDP Settings haben Matthias und ich uns in einem Thread schonmal ausgetauscht und Probleme mit ExchangeUM und SIP2Lync lösen können.

                    Die meisten Probleme haben sich bei mir durch die von Matthias erwähnte MediaBypass Einstellung gelöst.

                    Set-CsNetworkConfiguration -> MediaBypassSettings
                    Set-CsTrunkConfiguration -> EnableBypass

                    Das einzige was bei mir bis heute nicht wirklich läuft sind Verbindungen über Edge. Ich gehe aktuell davon aus, dass dies wohl zu SIP2Lync Geräten auch nicht wirklich durch die Lösung abgedeckt wird. Generell geht bei mir nur das was ich über MediaBypass lösen kann.

                    Viele Grüße aus dem Saarland
                    Pascal

                    Kommentar

                    Lädt...
                    X